The Orchid Forum, for the UK and Europe (previously known as The UK Orchid Forum) • View topic - Help
It is currently Wed Feb 21, 2018 2:44 am


All times are UTC [ DST ]




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: Help
PostPosted: Fri Apr 03, 2015 2:41 pm 
Offline
Probably run out of new things to post
Probably run out of new things to post
User avatar

Joined: Tue Dec 30, 2014 5:33 pm
Posts: 1001
Likes: 458 posts
Liked in: 399 posts
Images: 12
I live in: United Kingdom (England)
My nearest city or region is: birmingham warwickshire
Hi

I don't know whats happened, I'm wondering if it a fungle problem hpeing its not anything worse.

I have been spraying with a fungicide and it is only certain orchids it is affecting.

Coelogyne rochussenii and it also affected the new leafs.

Brassia Edvah loo all new growths are fine.

I keep humidity low to about 50%-70% in the winter months.
Also the temps are all ok as I do keep the C. rochusenii on the cooler side but it is growing along side dayan, velutina and massangeana and they have no problems.

I am considering to defoliate the plants as my C. Green dragon had something similar and its no all clean, after I took all the leafs off as I was a risk as it was still a seedling.
Any help would be great


Attachments:
problem 3.jpg
problem 3.jpg [ 118.9 KiB | Viewed 676 times ]
problem 4.jpg
problem 4.jpg [ 99.06 KiB | Viewed 676 times ]
problem 5.jpg
problem 5.jpg [ 142.94 KiB | Viewed 676 times ]
problem 6.jpg
problem 6.jpg [ 116.77 KiB | Viewed 676 times ]
Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group